Publicités

Experts disclose a Webroot SecureAnywhere macOS Kernel Level bug found months ago

Security experts disclosed a locally exploitable kernel-level vulnerability in the Webroot SecureAnywhere macOS security software.

The Webroot SecureAnywhere macOS security software was affected by a locally exploitable kernel-level vulnerability. An attacker that exploit the flaw could execute malware at the “kernel level” on a vulnerable Mac system.

The vulnerability, tracked as CVE-2018-16962, was patched months ago but publicly disclosed only yesterday.

“Webroot SecureAnywhere before 9.0.8.34 on macOS mishandles access to the driver by a process that lacks root privileges.” reads the security advisory.

The flaw is difficult to trigger, it is exploitable only by a local attacker that is logged into a vulnerable Mac system or by tricking an already logged-in user into opening an exploit through social engineering.

The vulnerability was discovered by researchers at Trustwave, the flaw was caused by the lack of validation of arbitrary user-supplied pointer being read from and potentially written too.

“Email Trustwave recently discovered a locally exploitable issue in the macOS version of the Webroot SecureAnywhere solution.” reads the analysis published by Trustwave.

“The issues root cause is an arbitrary user-supplied pointer being read from and potentially written too. As such, the issue arms an attacker with a write-what-where kernel gadget with the caveat that the original value of the memory referenced by the pointer must be equal to (int) -1.”

Under certain conditions, the issue could be chained with other exploit to gain a local privilege escalation.

The researchers pointed out that the exploitability of the flaw is limited in that the original value of the memory address dereferenced must be (int) -1.

A workable exploit could be implemented bypassing the KASLR (kernel address space layout randomisation) on the versions of OSX/macOS supported by SecureAnywhere.

Webroot addressed the vulnerability since July with the release of SecureAnywhere for MacOS version 9.0.8.34. At the time of writing, there is no evidence of any compromises from this vulnerability.

Trustwave decided to disclose only now the issue for the following reason;

“It is important that the details of our research are accurate and in order. Vendors at times issue a patch faster than we post full details on findings. We often provide users with more time to apply the patch before we release technical details about a vulnerability.”

SecureAnywhere webroot

Below the statement published by Webroot:

“The security of our customers is of paramount importance to Webroot. This vulnerability was remedied in software version 9.0.8.34 which has been available for our customers since July 24, 2018. We have no evidence of any compromises from this vulnerability.

For any user running a version of Mac not currently supported by Apple (OS 10.8 or lower), we recommend upgrading to an Apple-supported version to receive our updated agent and be in line with cybersecurity best practices on system patching.

Collaboration in the cybersecurity community is what keeps us all safer. We appreciate the Trustwave SpiderLabs team’s use of responsible disclosure to help protect the wider community from cyberthreats.”


Pierluigi Paganini

(Security Affairs – CVE-2018-16962, Webroot SecureAnywhere flaw)


The post Experts disclose a Webroot SecureAnywhere macOS Kernel Level bug found months ago appeared first on Security Affairs.

Publicités
Publicités
%d blogueurs aiment cette page :