AttachMe: a critical flaw affects Oracle Cloud Infrastructure (OCI)

A critical vulnerability in Oracle Cloud Infrastructure (OCI) could be exploited to access the virtual disks of other Oracle customers.

Wiz researchers discovered a critical flaw in Oracle Cloud Infrastructure (OCI) that could be exploited by users to access the virtual disks of other Oracle customers. An attacker can trigger the flaw to exfiltrate sensitive data or conduct more destructive attacks by manipulating executable files.

The cloud security firm dubbed the cloud isolation vulnerability in Oracle Cloud Infrastructure (OCI) “AttachMe.”

“We found the vulnerability while working on the Wiz/Oracle cloud (OCI) integration. When trying to attach to another OCI user’s virtual disk, we were surprised to find the operation succeeded! We received read/write access to disks in another account that does not belong to us.” said Shir Tamari, head of research at Wiz, said in a series of tweets. “Each virtual disk in Oracle’s cloud has a unique identifier called OCID. This identifier is not considered secret, and organizations do not treat it as such.”

The experts discovered that once obtained the OCID of a victim’s disk that is not currently attached to an active server or configured as shareable, an attacker could “attach” to it and obtain read/write access to it.

Oracle Cloud Infrastructure flaw

Oracle addressed the issue within 24 hours being notified by Wiz on June 9, 2022.

“Cloud tenant isolation is a key element in cloud. Customers expect that their data isn’t accessible by other customers. Yet, cloud isolation vulnerabilities break the walls between tenants.” reads the post published by the security firm. “This highlights the crucial importance of proactive cloud vulnerability research, responsible disclosure, and public tracking of cloud vulnerabilities to cloud security.”

Experts a added that the issue can be exploited only if the attackers’s instance is in the same Availability Domain (AD) as the target volume.

“This condition can be easily met as the number of availability zones is relatively small (up to three in some regions) and can therefore be enumerated.” added the experts.

“Insufficient validation of user permissions is a common bug class among cloud service providers,” Wiz researcher Elad Gabay said. “The best way to identify such issues is by performing rigorous code reviews and comprehensive tests for each sensitive API in the development stage.”

Follow me on Twitter: @securityaffairs and Facebook

Pierluigi Paganini

(SecurityAffairs – hacking, Oracle Cloud Infrastructure)

The post AttachMe: a critical flaw affects Oracle Cloud Infrastructure (OCI) appeared first on Security Affairs.

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

%d blogueurs aiment cette page :